Jump to content
  • GUESTS

    If you want access to members only forums on HSO, you will gain access only when you Sign-in or Sign-Up .

    This box will disappear once you are signed in as a member. 😀

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

eyeguy 54

Just Food and Drink

Recommended Posts

1 minute ago, leech~~ said:

 

There yea go Big guy!  Nicely done, you got points I'm sure for that one! 😘  

 

Actually I cook meals like that several times a week. 

Share this post


Link to post
Share on other sites
36 minutes ago, smurfy said:

Didn't cook much but wrapped all my venison trimmings. Sticks hot dogs and summer sausage 

IMG_20190215_181208530.jpg

 

Wow you got a lot of eatten to do there. What butcher do you use?

Share this post


Link to post
Share on other sites

Plantenbergs in Richmond mn. My kid gets some to. I sometimes give some to the other kids too but only if they behave. Your looking at #255.00 worth.

Share this post


Link to post
Share on other sites
13 hours ago, leech~~ said:

 

Wow you got a lot of eatten to do there. 

 

I would think any good Democrat would be up for sharing........😋

Share this post


Link to post
Share on other sites
2 hours ago, Mike89 said:

I have heard they do good work there..

They do. Born and raised on there meat. Still tough to beat.

Share this post


Link to post
Share on other sites
8 hours ago, smurfy said:

Plantenbergs in Richmond mn. My kid gets some to. I sometimes give some to the other kids too but only if they behave. Your looking at #255.00 worth.

 

Darn week late, we were in Richmond last weekend for grandsons hockey tourney. 

Share this post


Link to post
Share on other sites
55 minutes ago, leech~~ said:

 

Darn week late, we were in Richmond last weekend for grandsons hockey tourney. 

That rink is just east if where I grew up. See the big reddish color pole shed? My boats in there.  And you had to have gone through cold spring. I see how you are!😖

Share this post


Link to post
Share on other sites
1 hour ago, smurfy said:

That rink is just east if where I grew up. See the big reddish color pole shed? My boats in there.  And you had to have gone through cold spring. I see how you are!😖

 

Actually team lunch buffet at Marnanteli's then back to the next game! 😊

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



  • Your Responses - Share & Have Fun :)

    • We have a 6 year old Frigidare gas range and the ignitors on the top burners seem to be controlled by a ghost.  Sometimes one doesn't work, sometimes another.  Any ideas?   Thanks for your time. Tom
    • Make sure the adapter wiring matches the diagram on the cover of your female plug-in on your truck too.  Some use the center pin for backup lights,  yet others it is an auxiliary.  Also make sure that the lobe on the male is lining up with the lobe on the female plug-in too.
    • Trailer, one side, brake and turns dont work, same wire, same bulb filament.  Sounds like a ground problem.  With other tow vehicles its ok.  Are these 7 pin to 4s?  Could be the wrong adapter?  Not all 7 to 4 pins are the same.  Sometimes too that bad ground seeks its path through the hitch.  
    • Wrapping up the ice fishing after tomorrow. I’ve never owned a propane auger before this one and the one I have was bought used. Any storage tips?  
    • They are probably wired differently. I’ve seen this happen.    Actually I had a brand new 2015 Silverado 2500 diesel issued to me as a company vehicle and had issues galore with the factory wiring and the gooseneck trailer I was pulling. It was the biggest nightmare I’ve ever had and it was all with the factory Chevy wiring and integrated brake controller.   
    • Not the best time of year to be laying in the cold and slop under a truck tracking down wires but I have done that as well. Sounds like you then need to track down the yellow wire on the truck and see where it may be corroded and shorted somewhere.  
    • Thanks for the response leech. I purchased an adapter similar to that one with the test lights. Both trailers I tried are almost new and both have LEDS. All work great with Moms SUV and Dads truck. I’m thinking it has to be somthing corroded or a broken wire on the truck end. But figuring that out is out of my reach.
    • Sounds like it may be a bad harness on the trailer it's self.  Get one of these and test the truck again. If all works it's time to fix or replace the trailer harness. I've done both on the 5 different snowmobile trailers I have had over the years. It could just be a bad corroded or shorted rear light fixture on that one side or a shorted wire on that side.   ATB 16687 Truck Trailer Vehicle Plug Tester 7 Round Blade 4 Pin Wire Light Brake RV Tow  
    • I know this forum gets very little people now days but maybe someone could help me out. So I purchased my self a new ( to me) 2000 Silverado 1500 back in August. Be mindful this is my first truck/vehicle. So I tow often ( boat, snowmobiles, atvs, kayak). But the guy I bought it from had said all trailer lighting works great. So I didn’t think much of it. Well a few weeks after I bought it I hooked up a trailer to try the lights.... well. All running lights work perfect, but, no drivers side signal or brake light, passenger side brake light and signal work great. I have tried 3 different trailers and have tried them on 2 other vehicles everything works great. So first thought is Check fuses right? So it was in at a Chevy dealer getting some work done so I had them cheak it out. Fuses all look good and they told me all trailer lights work perfect. So I thought well maybe my 7 pin to 4 flat adapter was bad. I bought a new one of those and tried again. I got one with the test lights on it and sure enough all lights worked great UNTIL I hooked up a trailer. When I did this it kicked out the drivers side brake light and signal on the trailer. At this point I’m feed up with this issue and I’m to worried about getting nailed so I only tow a little ways from home. Anyone have any thoughts on what this could be? I was thinking maybe a bad ground on truck? But how would you know? And also this truck has spent it entire life in Florida until last May so this is the first winter in MN. But it shouldn’t matter since I tried the lights back in the end of August. Thanks a lot!
×