Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

huntercj

Vexilar FL-18 problems

9 posts in this topic

I am having issues with both of my fl 18 some of the modes don't work screen goes blank. Cant see my hook even with gain turned up. They are both pushing 10 years old,  is there any where to get them fixed and is it worth it ?

Share this post


Link to post
Share on other sites
5 minutes ago, huntercj said:

I am having issues with both of my fl 18 some of the modes don't work screen goes blank. Cant see my hook even with gain turned up. They are both pushing 10 years old,  is there any where to get them fixed and is it worth it ?

Yes you can get them tuned up but sounds like a bad battery to me.

Share this post


Link to post
Share on other sites

Had both fl 18 on for 6 hours each day  over the weekend with out dying think it still could be batteries ?

leech~~ likes this

Share this post


Link to post
Share on other sites

Cheapest thing to try is the battery, if that does not work then bring it to Vexilar and they will fix it for you.    I'd give them a call and they can diagnose over the phone.   One of 3 things likely.  1. Battery, 2. need new transducer (you can rule this out by using the ducer from your other unit) 3. Need brushes cleaned, but that usually impacts color and not signal strength.

Share this post


Link to post
Share on other sites

I've been having similar issues recently with my fl-18. I can see the bottom no issue, but rarely see my lure. The owners manual mentions to take water and rub the bottom of transducer to clean it. I used a sponge/water last nite and will try it this week. I have a new battery, so don't feel that's the issue. I'm leaning to the transducer going bad. Anyone have their transducer go bad on the ice models? Taz

Share this post


Link to post
Share on other sites

Thanks I will go pick up a couple of batteries I just didn't that vexilar would work on older units.

 

Share this post


Link to post
Share on other sites

It's very hard to beat Vex's CS. If the batteries don't do it, just take it in or give them a call(better than email) as they are very busy & that's the best way to get it fixed.

Share this post


Link to post
Share on other sites

I recently had to replace the transducer on my fl 20. The cord where it goes into the transducer had broken slightly and caused me to have to turn the gain way up and even then could barely see my jig. New transducer fixed the problem.  

gunner55 likes this

Share this post


Link to post
Share on other sites

On the vex web page, they had a section talking about poor sensitivity on transducer. It tells you how to check if the sensitivity is having issues, then it says at this point, not sure if it's transducer or the machine. They say if possible, use a buddies fl model transducer cord on your locator and see if you get good readings. If so, it's the transducer, if not, it's in the locator. Check the web page out for more info. Taz

gunner55 likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now