Jump to content
  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
mrpike1973

Honda lite Problem?

Recommended Posts

So I took my new Honda out today pumped it 3x started after 2 pulls moved to run. let it warm up a good 3 minutes. ran great then after a hour. i did the same thing except no priming started right up let it warm up 3 minutes started drilling bogged down and died in middle of drilling so i drilled a few more did it again started right up. after 3-4 holes then it ran fine maybe a little cold? this is the 4th strikemaster Ive had in 2 days. This is in another post anyway hope I didnt get a lemon again I was really impressed with it other wise very quit and started way better than my solo thanks

Share this post


Link to post
Share on other sites

Oil exactly what it said in the manual. also the dealer put it in and showed me how to check it. gas is fresh non oxy

Share this post


Link to post
Share on other sites

I just got one this year also. It did the same thing after a dozen holes but has not done it since and is a sweet auger, I love it. I use it hard and often. The only other prob I had was when I set it down in a wheel house right by the furnace to warm it up, that was not a good idea as it flooded it self from over heating. I think the gas expanded or something.

Share this post


Link to post
Share on other sites

Wasn't there something about the new gas caps that weren't allowing air to get into the tank so they were getting vapor locked. Try opening the gas cap after it does that and see if that helps. I think with the new regulations the caps can't legally vent anymore, not sure how there suppose to work now.

Share this post


Link to post
Share on other sites

I don't know if you are aware that running non oxy. gas in cold weather you will get carb. iceing.

Share this post


Link to post
Share on other sites

OK guys got it back faulty gas line with a kink in the hose. 2 days later for new parts. 10 below 0 this morning starts after about 4 pulls let it warm up 2 minutes drilled hee hee 50 holes no dying did many turn it off start back up I believe I hope its fixed. I'M almost falling in love with this thing. but I've been hurt before. Hee Hee here is hoping

Share this post


Link to post
Share on other sites

That's great. I do love mine. I was a diehard Jiffy guy but the Honda lite is really sweet so far. I run 4 houses and have drilled many holes this winter and I think re-opened more then new and it has served me well. The only disappointment is the 10" hole, its much smaller then the 10" jiffy. Haven't measured but its noticeably smaller but I can live with it.

OK guys got it back faulty gas line with a kink in the hose. 2 days later for new parts. 10 below 0 this morning starts after about 4 pulls let it warm up 2 minutes drilled hee hee 50 holes no dying did many turn it off start back up I believe I hope its fixed. I'M almost falling in love with this thing. but I've been hurt before. Hee Hee here is hoping

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×