Guests - If You want access to member only forums on HSO. You will gain access only when you Sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
LucasMN

Cruis-a-Day Gas Tank

Recommended Posts

Hey Guys and Gals.

My buddy has an older model boat motor. It has the 2 line fuel lines, going to a "Cruis-a-Day" or "Mile-Master" pressurized 6 gallon tank. I think these were from the early 60's. But anyway, the primer on the tank leaks like no other when priming, and then it leaks when it is pressurized. I have a couple questions, does anyone know where to buy the gasket set for one of these. And also, do any of you know where I can see how to put the guts of this thing together? I want to make sure we are not missing a piece. A HSOforum to view this would be best.

Thanks

Share this post


Link to post
Share on other sites

Many years ago I had a tank like that repaired at Avon Marine. I don't know if they're still in business. Bruce at Bruce's Outboard may be able to help. He's on Mayhew Lake Road about three miles north of SR high school.

Share this post


Link to post
Share on other sites

Unfortunately Avon Marine went out of business a while ago... they were bought by Crystal Pierz marine, which 5 or 6 years after they bought Avon Marine was moved to St Cloud and is now closed.

Bruce will probably be able to fix it though... seems like there's not much he can't.

marine_man

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



  • Your Responses - Share & Have Fun :)

    • Try going over to this thread. Rock & Edibles-Agates-Fossils-Artifacts-Mushrooms-Ginseng-Gems-etc. There is some discussion taking place under Morels' 2018 already.
    • Guys and Gals, I have searched high and low and have found none at all this spring.  Anyone have an success.  I am guessing it is too dry.  Will they still pop?  Any advise? "Set the Hook", Flash  
    • Wow, my spots are way behind this year. Had hoped to find a bunch before this coming long weekend for a big family Walleye and Morel fry but have only found 5 small grays so far. Just not seeing the ground cover growing very much yet and have saw no other types of mushrooms which seem to grow first pop up yet. This is a very late year so far.
    • No, shes not but on a paper thin rotted floor your kitty would fall through. I can see why she worried.  I didn't because it wasn't on my side!!
    • Yep, OTC. I wouldn't mind seeing some on beds. Seems like I usually get there just as the largemouth are wrapping up.
    • I have a group of bachelor drakes on the pond this year.  The pond water level is high so there is flooded timber. A great combo for photography.                                  
    • Well I had a little project that we found after buying our camper used. It had a leak in the back corner which 3 other same type campers in our camp ground had in the same spot. I sealed the roof a few years ago but have not had time to tackle the soft floor in that corner. Spent one weekend ripping out to find out what I had and a 3 day weekend repairing it. Had to build boxes as new supports to tie into the good wood past the rotted area. Really glad there were two metal frame supports under that end as I could span them with the new wood. Re-insulated and put new plywood down and it's looks great. Now my wife doesn't have to worry about getting into her side of the bed without going through the floor!        
    • Well I guess I could close the loop on my water heater since I finally had time to look at it.     I haven’t pulled the element yet but have filled the water and run through everything with my meter.  I’m 99% sure it’s the element.  I have 120V to it and it Ohms out at 2.  I figure that’s the water giving me that reading since the elements should Ohm out at 10 or more.  Basic rule I learned in shop: Power to the load; load don’t work; load is broken.  Looks like a $15 part.   What I did enjoy learning is getting the propane part of the heater operational.  Never had that before since the wire harness was apparently always disconnected from the ignition module.  I plugged that in and she fired right up.   Now to get my sealants put on tomorrow and clean and lube the bumpout gaskets.  I bought some LED light bulbs to try also.  And time to get a bigger TV installed in the main living area.  That 13 inches just doesn’t cut it with my eyes anymore!