Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
JimBuck

Minnkota Powerdrive 55lb. Trolling Motor stuck on high?

3 posts in this topic

I've got a problem that I wanted to see if anyone else has experienced. My trolling motor has been only able to run at full power whenever it turns on. Steering and start/stop work fine but the speed is stuck on the maximum level. I tried adjusting with the foot pedal and the remote but still no luck? Any bright ideas? I've seen past threads in regards to this issue but those affected by the issue also had other problems with the on/off function. Thanks everyone.

Share this post


Link to post
Share on other sites

You didn't say which trolling motor, but it sounds like issues with the switch in the foot pedal. I had the same issues, but it wouldn't work at all. So I bypassed the switch and now it runs on high power only. I don't see it as much of an inconvenience, but that's just me.

Share this post


Link to post
Share on other sites

It has something to do with internally is what I'm thinking. The handheld remote works in the same manner...turns, on/off but is stuck on High when turned on. The high power setting is a nuisance when I'm bass fishing as it really jerk-baits the boat around when I need to turn it on.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0