Guests - If You want access to member only forums on HSO. You will gain access only when you Sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

  • Announcements

    • Rick

      How to create an @mention - Click Here   07/16/2015

      You can use the @mention aspect whenever you want someone to be notified about a post or let them know you are talking about them. Type the @ symbol type in a couple "lowercase" letters pause then once the names pop-up either select or keep typing in letters to narrow down the list until you get the @mention name you are looking for. You can play a game so members can see how it works. If you want to practice or If your name has been @mentioned below you should see it in your notifications (upper right) and you then have to @mention one or two members who haven't been mentioned inthe comments section below. Let's see how long we can keep this going. Anyone who duplicates a name that has already been @mentioned loses. This is the first group to be @mentioned to get the ball rolling: @Borch @Scott K @Corey Bechtold @Matt Johnson @mrklean @eyeguy 54 @Finns @IceHawk @MarkB @Cliff Wagenbach @Wayne Ek
Sign in to follow this  
JimBuck

Minnkota Powerdrive 55lb. Trolling Motor stuck on high?

Recommended Posts

I've got a problem that I wanted to see if anyone else has experienced. My trolling motor has been only able to run at full power whenever it turns on. Steering and start/stop work fine but the speed is stuck on the maximum level. I tried adjusting with the foot pedal and the remote but still no luck? Any bright ideas? I've seen past threads in regards to this issue but those affected by the issue also had other problems with the on/off function. Thanks everyone.

Share this post


Link to post
Share on other sites

You didn't say which trolling motor, but it sounds like issues with the switch in the foot pedal. I had the same issues, but it wouldn't work at all. So I bypassed the switch and now it runs on high power only. I don't see it as much of an inconvenience, but that's just me.

Share this post


Link to post
Share on other sites

It has something to do with internally is what I'm thinking. The handheld remote works in the same manner...turns, on/off but is stuck on High when turned on. The high power setting is a nuisance when I'm bass fishing as it really jerk-baits the boat around when I need to turn it on.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this