Jump to content

    If you want access to members only forums on HSO, you will gain access only when you Sign-in or Sign-Up .

    This box will disappear once you are signed in as a member. ?

HDS 10 problems


Recommended Posts

Took the snobear out on lotw last weekend and was having some issues with the lowrance HDS 10 that were causing some frustration to say the least. First of all, the thing takes literally 10 minutes upon startup to get past the blue lowrance welcome screen. It did this on the first start up as well every time it was restarted over the whole weekend without getting better. If anything, it got worse. Took the unit inside overnights so temp wasn't the issue. Anyone know how to speed up this start up process? Does it always take this long? I am a humminbird guy and don't know much about lowrances but the 1198 bird always starts up in about 15-45 seconds at the very most, so the lowrance seems like there is an issue causing the delay...

The other problem we are having is we could not get the lotw lake map/contours to show up... Keep in mind we have had this exact setup with no issues for the past 2 winters... Same unit, same lakemaster chip, except for some reason this weekend we could not get the contours to show up. I tried taking the chip out and putting it back in, switching the chip to the other sd card slot in the unit and tinkering with every feature possible in the menu to try and get the contours to show up. When going in the chart menu options, for some reason it only had "lowrance" and "navionics" as options of chart info to display. The chip is a lotw lakemaster chip. The only thing I can think of is somehow the chip went bad. Like I said, we have used this exact setup (HDS 10 unit And lakemaster chip) for The past 2 winters and never had any issues with the lotw contours showing on the gps maps. I even tried resetting to factory default settings and still couldnt get the contours to show. Does anyone have any ideas? Like I said, I am a humminbird guy and really dont have much knowledge with lowrance stuff

Link to comment
Share on other sites

I'm guessing its having a problem reading the mapping chip for some reason, that's why the contours aren't showing up.

Pull the chip and restart to see if that solves the start up issue. If it boots up in a few seconds, then it's either your mapping chip, card reader, or some software glitch. Try a different mapping chip to see if that helps. Also, check to make sure you have the latest software version installed. The latest version is available under "Downloads" on Lowrance's HSOforum.

Jim Carroll NPAA #13

Link to comment
Share on other sites

Join the conversation

You can post now ↓↓↓ or ask your question and then register. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.