Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
kevfish1

cruise control

7 posts in this topic

1998 dodge ram. When I set the cruise after a few minutes the cruise "slips" I set it and after a few minutes I am going 5-10 mph slower. Is this an expensive fix????

Share this post


Link to post
Share on other sites

My first guess with out digging into it would be cruise control servo. What speeds are you driving? I know the cruise will shut off around 35-30 mph on its own.

Share this post


Link to post
Share on other sites

Ahhh found what servo is on internet. Any idea where this would be on a 1998 doge pickup????? Expensive fix??????

Share this post


Link to post
Share on other sites

I can not remember if this one is located under the battery or up on the engine?

Which Ram is it and what engine does it have in it? You can also check for damaged vacuum lines going to or at the servo also.

Share this post


Link to post
Share on other sites

I would almost bet it is located under the battery on a 1500.

It would look like this:

0900c152800713ab.gif

0900c152800713a7.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0