Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
eyeguy1

Electrical issues w/ 7 prong- 2001 F-150

3 posts in this topic

Looking for some quick advice- I am having problems with my 7 and 4 prong hookup on the truck for trailer lights. Has never worked correctly- When I plug into any trailer my lights work, and my brakes work- my signals make both my truck tail lights flash at the same time as well as both trailer lights flash. My signals dont work at all if my lights are on or I am stepping on the brake. I checked and it is grounded- do I need to have my 7 prong replaced? The truck came with trailer tow package so it looks to be done in the factory. Any ideas would be appreciated.

Share this post


Link to post
Share on other sites

Sounds like your truck is not grounded. If it is factory wiring I would start by checking the connectors near the 7 pin for either corroded pins or incompletely connected. Both are common with fords. If the pin is corroded you can bypass the wire around the connector.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0