Jump to content
  • GUESTS

    If you want access to members only forums on HSO, you will gain access only when you Sign-in or Sign-Up .

    This box will disappear once you are signed in as a member. 😀

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
walterman

Vex Battery Indicator Problem

Recommended Posts

I have had a FL-20 for about 3 months and the batter indicator stopped working. The "on" light still comes on but the percentage light dont. Anyone else have this issue?

Share this post


Link to post
Share on other sites

yes ive had a similiar problem with my fl-12 i think the indicator is broke it says i only have 75 percent after about 10 minutes. Then after about 5 hours it says the battery is dead but then it last another 12-15 hours. Theyre junk if you ask me.

Share this post


Link to post
Share on other sites

I had the exact same problem with my FL18 earlier this year. Charged my battery for a couple of days before the season started and the charge indicator said 100%. Within 5 minutes, it would be 90, then 50 and so on until just the power light was on. I didn't take a chance, so I bought a new replacement battery. That was the problem-the battery was shot. I have litterally used my vexilar this winter for hundrdeds of hours and charged the battery every night and it has been working perfectly- the 100% light stays on for approximately 12 hours of fishing. A new battery with charger will be about $35.00

Hope this helps,

Justin

Share this post


Link to post
Share on other sites

Hmmmmm, I bought a "recon" Vex from the factory last year. I brought it home and charged the battery and the "Charge Complete" light has never came on. I have been out on the ice with it many times and 8 hours is about the longest that I have been using it and it runs great the whole time. The charge indicator only shows the power light and nothing else. I just figured that the lights were useless. Maybe I should look into a new battery? Maybe I should stop by Vexilar on my way home some night and ask them about it? Things that make ya go Hmmmm. Take care and N Joy the Hunt././Jimbo

Share this post


Link to post
Share on other sites

Alright I just recieved an email from the customer service and said they have had a few cases where the indicators were bad. After a couple of emails they are sending me a new indicator free of charge and it should be at my door in a day. For not speaking to anyone in person I thought they had a fast response time and great service.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×