Jump to content
  • GUESTS

    If you want access to members only forums on HSO, you will gain access only when you Sign-in or Sign-Up .

    This box will disappear once you are signed in as a member. 😀

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
frozenfeet

HELP - Vexilar FL-18 issues

Recommended Posts

Has anyone had a problem with the bottom indication on the zoom side of the display moving up to the 2' mark on the scale? I just had the new update done by Vexilar and it was supposed to fix that. Now it is still happening. It will go back down to the 0' mark if I shut the vexilar off and turn it back on. My FL-18 is one of the first ones that were sold. This seems to happen if it is on for an hour or two steady. Kind of worthless considering it should be on all the time while you're fishing. I'm really curious if anyone else has this problem??

Share this post


Link to post
Share on other sites

i experience the same thing. i thought it was a loose cable but that is not it. i think i might have to live with the problem, i dont know if vexilar can do anything about that can they??

Share this post


Link to post
Share on other sites

This is an issue with the FL-18...mostly when pulling from one hole to another in AZ mode, or when pulling transducer to ice a fish and then dropping back in. Vex's fix is...turn to Normal, turn gain all the way up...turn back to AZ...then adjust gain back to your previous mode. Its a pain in the rear...but thats what you have to do. OR, go back to normal before pulling the transducer out of the hole...

or......ask CNYTim what he would do wink.gif

Share this post


Link to post
Share on other sites

I've had the same issue. It seems to go away after a little bit, but like you say, it appears that the bottom jumps up to 2 feet on the zoom side. Sounds like there are a few remedies, but whats the cause? Good post!!

Share this post


Link to post
Share on other sites

By the way, welcome to the site Frozen Feet. Hope you have some time on your hands, cause this site will keep you comin back for more...and more...and more.... Theres a TON of post about Vex's here...just do a forum search either here or on the equipment forum. More tips and info then you can shake a jig stick at!!!

Share this post


Link to post
Share on other sites

I have the same stupid problem with mine! Sometimes it is way worse-especially in really clear water. Ive had it messed up all the way past the 5' mark at times and no matter what you do it will not go away. I wonder what that is all about? Hopefully someone from Vexilar will see this post...

Justin

Share this post


Link to post
Share on other sites

The original problem was initially soft bottom reading, basically the zoom would not hold, had the update free of charge from Vexilar and two outings later the same thing happened. Sold it immediately and purchased another LX-3, end of story...

Share this post


Link to post
Share on other sites

Thanks Tim, I was wondering if you missed my (mostly) tounge in cheek remark!!grin.gif

It really IS a pain to deal with...but I will have to deal with it for a couple more years at least until a new.....flasher...is in my budget!!

Share this post


Link to post
Share on other sites

I had just received the Vex back from Vexilar Inc. just before December and they performed a free software upgrade that was supposed to solve that problem and it didn't. I guess I'll be sending Vexilar Inc. another e-mail!!! confused.giffrown.gif

Share this post


Link to post
Share on other sites

Let me know what they say, Feet, cause I sent mine in and they sent it back with the instructions on how to counter it...which makes me think they cant really "fix" it. Now, my buddy has the dual ducer and it doesnt happen to him as often...

Share this post


Link to post
Share on other sites

I also have the same problem. A quick power on/off usually takes care of the problem. I've had my FL-18 for 3 years now. I see people on this post mention an "upgrade" from Vexilar. Can any one tell me about this "upgrade" and if I need to send my 3 year old unit in to have this done. Thanks.

Share this post


Link to post
Share on other sites

I recently took my fl18 to vexilar because I thought it made to much noise. They were very helpful and fixed my problem and during our conversation I brought this problem up to the tech and he told me to do what everybody here is saying turn it off then on, Never said anything about an upgrade.

Share this post


Link to post
Share on other sites

It is a circuit upgrade for Vex's with a serial # within a specific range...if yours is 3 years old you may want to check it out. I sent mine in to get the 300' mode upgrade..they just somehow zap the circuit board and the "upgrade" is done. I did mine 2-3 years ago...The problem is as simple as when you move the ducer while the unit is on in zoom mode, it loses bottom and has a hard time re-aquiring...unless you turn it off or adjust from AZ to norm and back. Go to Vex's web site and poke around

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Your Responses - Share & Have Fun :)

    • Good yo hear from you again!  Hope your search for property goes well and your time in stand is fruitful.
    • Nice pics jbell! That is a nice yellow garden spider you got there.
    • I had a nice size garden spider on my garage door. It stayed there about 3 weeks. Had a mate who I assume did his business and met his doom. I finally needed to open the door so I safely caught it and let it go in the woods near our house.  Her body is about an inch long. Probably about 3 inches total.       
    • 😄i have several "pet" spiders around the deck and garage. sometimes when i'm bored i swat flies with the swatter and feed them!!!!!!
    • its wierd, my cukes the stems from the ground out look like they were died and dried out but the ends were green, plenty of flowers and producing.quite frankly, i got 2 medium size boxed of cukes in the frig i need to use or give away. i know this isnt right to say, i'm getting cucumbered out.   same with the peppers, i had to look thru a jungle to find them most of the summer as the cukes exploded and basiclly covered them. i have enough peppers for what i need, froze some for chili, and have eaten my share. and again there were no small ones coming in to keep them in the ground to make it till first frost.   my tomatoes, the ones i may be pulling soon are running out of tomatoes worth while . 
    • That's too bad, did your garden get dried out at some point? You had a pretty good start to the season and had a jump on my garden.
    • I assume you burned your deck down immediately after taking these photos.
    • Never been a big fan of webspinners, but those orb weavers are cool to look at and harmless. And this is the time of year that you seem to see them.   More of a fan of Wolf and Jumping spiders myself.  
    • Cool!  Did you take a picture when you smashed it? That big som-abatch could use a 22 through it! 😘
×