Jump to content
  • GUESTS

    If you want access to members only forums on HSO, you will gain access only when you Sign-in or Sign-Up .

    This box will disappear once you are signed in as a member. 😀

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Juneau4

Check Engine Light

Recommended Posts

2006 Silverado  When ever I fill it the light comes on, but then will go out once I get to 3/4 tank and stay out. If I add gas and don't put in more than 3/4 tank it remains out. 

Any ideas --I'm thinking gas cap.

Share this post


Link to post
Share on other sites

Yep, gas cap needs to be replaced.

 

I bought a used Blazer once days before a Deer opener. Never had a GM before that. I packed it up and went to fill it up. A few blocks from the station the check eng light goes off! 😣

Buzzed over to a near by dealer and lucky to get in.  The tech writing up the work order once he found out I just got it said, let me check something. Open the gas fill cover and turned the cap a few times. He said it should be fine now! ☺️

Edited by leech~~

Share this post


Link to post
Share on other sites
4 hours ago, leech~~ said:

Yep, gas cap needs to be replaced.

 

I bought a used Blazer once days before a Deer opener. Never had a GM before that. I packed it up and went to fill it up. A few blocks from the station the check eng light goes off! 😣

Buzzed over to a near by dealer and lucky to get in.  The tech writing up the work order once he found out I just got it said, let me check something. Open the gas fill cover and turned the cap a few times. He said it should be fine now! ☺️

Thanks I thought it may the fuel cap, next time before I fill I'll crank the cap a few times and see what happens.

Drives me nuts even thought oil pressure and temp is fine. I may try it tomorrow I'm between 1/2 and 3/4 and all is fine.

Share this post


Link to post
Share on other sites

Could always stop by an auto parts store that offers free code reading for check engine light....O'Reilly is one that does, as I recall.    Also Advance Auto Parts...    Even a normal service place might.

 

Share this post


Link to post
Share on other sites
1 minute ago, delcecchi said:

Could always stop by an auto parts store that offers free code reading for check engine light....O'Reilly is one that does, as I recall.    Also Advance Auto Parts...    Even a normal service place might.

 

 Thanks  I'll do that. Stop at O'Reilly and see what they say.

Share this post


Link to post
Share on other sites
On 9/11/2018 at 9:08 PM, Juneau4 said:

 Thanks  I'll do that. Stop at O'Reilly and see what they say.

It will be interesting to hear what it is. 

Share this post


Link to post
Share on other sites
3 hours ago, delcecchi said:

It will be interesting to hear what it is. 

That's on my plan for this afternoon.

Share this post


Link to post
Share on other sites

Did  O'Reilly (or who ever) reset the light warning (?) system?  If so, give a quite a few miles to see if it comes back on.  Had a light come on, they reset the system and later the light came back on.

Share this post


Link to post
Share on other sites

No, we just put a new cap on and I went and filled with gas and it stayed off and has remained off. It would come on when I had 3/4 + tank of fuel and go out when I had less than 3/4 tank. All is good so far, but I haven't put 50 miles on.

Share this post


Link to post
Share on other sites
On 9/14/2018 at 5:36 AM, Juneau4 said:

Put new fuel cap on and filled tank- no light came on, so problem seems to be solved, have to see if anything changes.

 

How's it so far? A buddy of mine got a Silverado who's experiencing the same. I came over last weekend to help him install the new rails, lund truck bed cover and rack for kayak mount and took it for a test drive/refill gas. CEL lit on for about a minute and turned off. He said it happened twice last month, it got a new cap last September.

Edited by GrahamD

Share this post


Link to post
Share on other sites
49 minutes ago, GrahamD said:

 

How's it so far? A buddy of mine got a Silverado who's experiencing the same. I came over last weekend to help him install the new rails, lund truck bed cover and rack for kayak mount and took it for a test drive/refill gas. CEL lit on for about a minute and turned off. He said it happened twice last month, it got a new cap last September.

No problems with it, light has stayed off ever since I put a new fuel lid on.

I suppose in the next week it will show up again--then again maybe not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Your Responses - Share & Have Fun :)

    • We were up fishing from last Thursday afternoon through Saturday evening. Fishing was great, lots of nice walleyes with a couple of fat 28" fish as the biggest and plenty of saugers. Fish bit all day with our best bite coming each day from about 2-315. Fish were somewhat sluggish from 11-1230 and had to be coaxed into biting or didn't bite at all but after 1230 most everything we marked bit. We were set up in 23-24', color didn't seem to matter although we tend to use gold more than most other colors on our spoons and we basically had every color tied on our set lines and they bit them all. There was about 3-4" of snow on the lake Thursday when we got there but it was a packed 1-2" by the time we left Saturday night. Some areas of rough ice but other areas are nice and smooth, generally about 14-16" of ice where we fished. Can't wait to get back up, good luck if you are going out!
    • That's the way most falls go. I was able to get out and put a gobbler down this fall. Went out just for a bird since I knew where they had been going in the morning. Got to the woods just after fly down and worked my way to the area and heard them talking a bit. Gave out a few yelps and had them running to me.
      Most years I never get a shot only have taken a handful in the fall. I was in a woods that I was not worried about ruining for deer.
    • Now that the corn is out and the ground is white the birds are really showing themselves. Three times in the last month I have seen 50-60  birds on a short day. Nearly every one was in a group and they are concentrating in dense thickets of plum brush.    And there are literally next to no hunters out and about going after them which is a big change from even a decade ago
    • I too remember these stupid punch cards in High school.  All the Nerds in the Computer class did stuff with um! 😅
    • I remember those stupid punch cards.  I was in junior high and had to “program” em in class.  I hated em and thought I’d just avoid using computers altogether! 😀
    • Good hunt in SD today: 
    • Had the day off so hit some public land around the Mitchell area today.   Did well, my favorite upland gun is my O/U and is currently broke. Busted a firing pin and waiting for gunsmith to get a knew one made on a lathe. So today I brought out the old 870 which I haven’t shot in at least 5 years or more.   Thought it would throw off my shooting but to my surprise managed a quick double on 2 shots lol. it’s always amazing how fast a day in the field can turn around. And I really enjoyed shooting this gun again. It’s amazing how something so cheap and simple is so good.   Day started out really slow I couldn’t find birds anywhere and then found the motherload. Shot my 3rd bird, put it in my vest and bumped birds all the way back to the truck.   Good late season hunt just wish we had more snow. And this warm weather isn’t helping ice that’s for sure.  
    • Looks good!  👍 Lets see no work gloves, may be a hat?  Do you have a coaster under that hot pan mister? 😊
    • Steak fajitas tonight.
×