Jump to content
  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
Notime

Jeep. Again!

Recommended Posts

The other day I was on my way home from work and my 02 Jeep GC 4.7 beeped at me. I had no clue and I couldn't see anything. I got down the road and it beeped again. I made a right onto a gravel and it beeped twice and I still couldn't see why. I drove almost 4 miles and it beeped again only this time it said check gauges. I had no oil pressure. I changed the oil as it was a little low and close to a needed change. I drove it tonight and as I got to my destination it beeped and lost oil pressure. When I left oil pressure was right up where it is normally, 6 miles later as I pulled into the yard I lost oil pressure again. When I pulled into the yard the pressure was dropping to about 1/4 on the gauge but when I stepped on the gas it came back up. I have noticed that it seems to loose pressure when it gets good and warmed up. What am I looking at? Sending unit? Bad connection? or is this how an oil pump acts when it goes out? Thanks for any help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×