Jump to content
  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
Pedro77

LX-7 voltage meter

Recommended Posts

Hello everyone. Just wondering if anyone else has had issues with the voltage gauge not working on the LX-7.

Just picked one up Sunday. Had v2.9, meter didn't work. Updated to v3.17, still not working. Just shows 9 volts and says Lo Volt. Although, if I check at the pigtail with my multimeter, it shows 12.74 volts.

Share this post


Link to post
Share on other sites

Does it read the same or different with another good battery?

If its defective either return to swap or take over to Marcum headquarters to have the issue corrected.

Share this post


Link to post
Share on other sites

Haven't tried a different battery yet. The box was not factory sealed when I bought it, but unit seems to be new aside from the transducer being scratched. Hope I wasn't sold a returned, defective unit. I will contact Marcum today. They've always been helpful in the past when I have needed service.

Share this post


Link to post
Share on other sites

I know what happened. Same thing happened to me. When the Marcum was first purchased it had the newest software at the time, then the 2.9 was installed. This will cause the Voltage Meter to malfunction. either send it to Marcum direct and they will fix it up, or return and state what has happened to the customer service. They will have return to Marcum. Either way this unit will be defective unit fixed from Marcum. Marcum customer service is top notch and are very helpful. Hope this helps

Share this post


Link to post
Share on other sites

This is going from the 3.01 to the 2.9 software. Updating a software with the software below your current package(downgrading).

Did you "downgrade" it yourself? I thought Marcum said that you couldn't do that? Have you tried going to 3.17? If your battery is testing at 12.7 v them I don't think it's a battery issue.

Joe

Share this post


Link to post
Share on other sites

Did you "downgrade" it yourself? I thought Marcum said that you couldn't do that? Have you tried going to 3.17? If your battery is testing at 12.7 v them I don't think it's a battery issue.

Joe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×