Jump to content
  • GUESTS

    If you want access to members only forums on HSO, you will gain access only when you Sign-in or Sign-Up .

    This box will disappear once you are signed in as a member. 😀

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
iceranger792

50 hp Force starter problem?

Recommended Posts

I have a early 90's force thats only seen about 8 tanks of gas in its life.

I was out today and i went to start it up and it was cranking strong like always. then i went to turn the key a 2nd time and "Nothin". I checked the fuse and it was blown so i threw a new one in and still nothin. i have a brand new battery so thats not the problem. any advice would be Greatly appreciated!

Share this post


Link to post
Share on other sites

You will need to get a 12v test light and begin at 1 end or the other until you determine where the voltage stops. I suspect you will find a bad connection somewhere. Corrosion or a poor connection will create resistance, blow fuses and prevent continuity.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Your Responses - Share & Have Fun :)

×