Jump to content
  • GUESTS

    If you want access to members only forums on HSO, you will gain access only when you Sign-in or Sign-Up .

    This box will disappear once you are signed in as a member. 😀

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
Guest

So who went shoping for raingear today?

Recommended Posts

Guest

I may have caught the biggest largemouth I'll get this year -- other than that, pretty much a wet, cold, slow outing. The season has begun.

Share this post


Link to post
Share on other sites

Went to the Mississippi just below the St Cloud dam and caught a lot of catfish, a few smallmouth, and 2 little walleyes. It was good to get out though.

Share this post


Link to post
Share on other sites

Fished the St. Louis river, caught 1 eating size walleye. Wind off the lake, temp in low 40's, and light rain. Most boats I saw caught nothing, a very small percentage did well. It felt great to get out, and by 4:00 pm my wet boat was put away. Yes, it was a good day to get rain gear.

Share this post


Link to post
Share on other sites

It was a wonderful day no rain and low variable winds and FISH! My son (just moved back from the State Washington) and I decided to try Buffalo Bay, LOW, we hunted all over until we found some nice male walleye in 5 1/2' in the rocks, ended up with 6, 16" up to 21", caught them on a minnow and chartreuse fuzzy grub jig.

Share this post


Link to post
Share on other sites

Fished out of Ely area. We had a party of 9. Kept 54 2-3 lb.walleye's and released at least that many. Some big northern's mixed in and a 4.5 lb. Samllmouth released. If that wasnt enough I released a 32 in. walleye during sat. night in the gail winds. Also my nephew relaeased a 30in. a half hout later.
st30in.jpg
st32in.jpg

[This message has been edited by Pwaldow123 (edited 05-16-2002).]

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Your Responses - Share & Have Fun :)

    • Was at Long Point this past weekend. Lots of small fish, no slots from us......
    • Ill let dealer plug into computer and see what shows up. 
    • Pigger steak on the grill, taters and corn. Yea yea, I get docked etiquette points for no serving dishes.
    • I suppose there is no check engine light code plug in on those like a car? Sometimes you can read and clear a misfire code. Did you try switching plugs out on the trail?
    • Had scratchers down but probably didn't matter much. Wasn't overheating and temp on gauge stayed at 160. Another guy in club thought it might also be bad gas and a misfire settting off check engine. Ill see what they come up with when they plug into computer. As far as electronic reverse lots of problems with it on internet. Fuse wasn't blown and I also bought and changed the 2 relays that people have had problems with and still nothing. I think the Servo motor crapped out as those have had problems to. I just hope it doesn't take to long to fix as spring is around the corner  
    • Wow, sorry to hear all that.I call it the Northshore curse!  Did you have your scratchers down? Or do you think it's just a short somewhere?  😟
    • it takes some practice. I was skeptical at first also but friends did great on them so made the switch and I use them 95% of the time for gills and crappies now.  Still learning
    • Made it up to Silver Bay for a ride on Saturday. Got about 15-20 miles down trail and sled starts to miss and wants to die and check engine light comes on. Shut it off and look things over and everything looks OK and not overheating. Start back up and runs fine for about 10 miles and does same thing. Did this about 4 times till we got to Trestle Inn. Im thinking its bad gas so was going to go put some premium in it to see if that helps. Start machine and put in reverse and back up and hit button to take out of reverse and nothing happens. Reverse fail comes up on gauges not good. Only good thing was stranded in Trestle Inn parking lot instead of woods. Gave guy I was riding with my car keys to come back with my truck and trailer and went and drank beer for a couple hours. Finally get everything back to motel and get organized and come back out to get some stuff out of truck and step on back of trailer and it flips up. Someone must have helped themselves to my tilt trailer pin as it would have never fell out on its own. Had to run to town on Sunday and round up a pin for trailer and dropping off sled at dealer tomorrow. At least its still under warranty.  
    • Thanks Presidents for the day off!  😁   Went back over to the same trails by Orock and hit it pretty hard to burn off some of the carbon I built up pulling the grandkids and sleigh around the other day. The trails were groomed and not bad but the groomer seemed to have put some pretty deep grooves in the trails around the corners. Never really saw that before anywhere? 🤔 There were a few folks out but no where near last weekend. My top end rebuild seems to be breaking in pretty well and the compression has been going up the last few rides so hopefully I'm almost there. 🤗    
    • I picked up some impulse mayfly plastics and mud bug jigs. I have tried plastics in the past with mixed results. I expect good things from the impulse mayflys. It would be nice not to have to mess with live bait.
×