Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
Big E

Help - Trolling Motor died

4 posts in this topic

Got a 7-year old Minn Kota Power Drive 65. It worked for the first 3 hours today. Then, out of the blue, I went to kick the throttle on, and nothing! The motor will still turn right and left, and when you hit the throttle you hear the customary "click", but the prop never turns. I took the prop off to check for obstructions, but that was fine. I can spin the prop by hand, but the prop never turns with thrust. Basically, it's like it's no longer getting electricity to the motor.

Any one have this issue? Any solutions? Or is this a complete replacement?

Share this post


Link to post
Share on other sites

I have had this happen a couple of times. The first time, it worried me a little bit. I just unplugged the foot pedal and plugged it back in and everything worked fine. The second time I had to disconnect it from the battery and reconnected and everything worked fine. I'm not a big fan of the PowerDrive models and this will definitely be my last.

Share this post


Link to post
Share on other sites

Make sure the batteries are good and fully charged. Also, the contacts on the speed control have a tendency to get corroded, slide it back and forth a few times to remove anything that may have built up.

Share this post


Link to post
Share on other sites

This happened to me and I ended up buying a new foot pedal at Fleet. $70 later it works fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0