Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
ilovefishing

boat trailer brakes

3 posts in this topic

i have a friend of the family who has a boat with trailer brakes installed last year and now they aren't working. i have checked the ground and power wires(has continuity) with the slide lever engaged only registered .05 volts. my question is this what it's supposed to be(according to the troubleshoot it sais there should be 25-50 amps. at the truck end i connected to the ground terminal and the brake power terminal it lights my 12 volt test light there, but when i try to do the same at the brake end does not light up at all. both magnets seem to buzz when lever is engaged. found that the inside of drum is rusted a little (anyone have any luck with putting trailer bakes on a boat trailer. thanks for any advise

Share this post


Link to post
Share on other sites

when i try to do the same at the brake end does not light up at all.

What do you mean by this statement? Where are you checking it?

marine_man

Share this post


Link to post
Share on other sites

not working; as in not engaging?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0