Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
leechmann

Aqua-vu

5 posts in this topic

I have an Aqua-vu z series camera. It's about 4 years old. It seems like the picture is kind of fuzzy now. Wondering if anyone else has had this problem. Wondering if it can be fixed or is it time to look for a new camera?

Thanks

Share this post


Link to post
Share on other sites

I'd call them up and ask. Nature Vision Inc. 1-218-824-3800.

Otherwise make sure your camera lens is clean and make sure your using the on switch in the on position that doesn't use the light. I've noticed mine is a little fuzzier on the light on position.

Just another thought,..... your eyes are ok right? Just kidding but I've recently had to start using glasses and wow can I see better!

Share this post


Link to post
Share on other sites

Have you got any moisture in the camera body? I had a problem with my camera, a different model, and it was taking on just a bit of moisture. I took it apart and dried it, siliconed the edges, and now it's as good as new.

Share this post


Link to post
Share on other sites

The temp gage in mine died, had a 50ft cable, camera still worked but temp was off about 20 degres high. I don't think the water under the ice is at 66 degrees. Bought new camera with 100ft cable works great.

Share this post


Link to post
Share on other sites

As Ron said call Nature Vision. They will sell you a new monitor and you can use your old camera. Your choice 5 or 7 inch screen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0