Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
bisekb

04 F6 questions

2 posts in this topic

Just bought a 2004 f6, 500 miles and So far i LOVE it. I know all the recalls have been done and ive heard about the sensor for the oil light tends to go on early, but has anyone heard of any other common problems with the sled? I wanna try and get as many bugs worked out as soon as possible so any tips or info would be awsome. thanks alot guys.

Share this post


Link to post
Share on other sites

I'm not aware of "common problems" with the sleds. I have a set of F5's and love them both. The one thing with the Firecats is the factory oil pump settings. My machines were using way too much oil, I calculated 35:1 when it is supposed to be 50:1 range. One tank of gas and the oil light came on...too much. I'm running around 55:1 and the oil consumption is A LOT less.

Run synthetic oil in these only. I choose Amsoil Interceptor and the power valves hardly need any cleaning, and great performance.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0