Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
bearslayer

Aqua View Problems

5 posts in this topic

When I turn on my Aqua View Scout, the pictures shows up for a second and then the screen goes white. Every time I turn it off then on again, same thing, picture there, then gone again. My buddy has the same one and has same problem. Thanks for any help in advance.

Share this post


Link to post
Share on other sites

Brightness cranked to full blast? Maybe button on far right is set for other camera.

Share this post


Link to post
Share on other sites

I tried all that. I even took thing completely apart to clean it. Figured might as well since fish weren't biting.

Share this post


Link to post
Share on other sites

I would call Nature Vision. Call this number and Jon will direct you to who you need to speak to. He takes care of the flashers but it will be a good way to contact someone rather quickly.

Jon Marshall

218-251-7991 - Direct

Share this post


Link to post
Share on other sites

I agree with Tom, get a hold of them. I had a problem like that and it ended up being a short in my camera cable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0