Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
Ironranger

battery for sled help.

4 posts in this topic

help.

I bought the kids a 94 artic cat 340 pantera to learn the fun of sledding.

It needed a new battery, so I bought a new one, apparently for that type of battery there is a left post version and a right post version.

well i bought the wrong one, and very stupidly hooked it up reverse polarity, tried starting it after charging, and got no response at all when trying to start it of course.

I reversed polarity, and it still does nothing at all. I know the battery is good.

What harm have I done? Have I burned something up, like the iginition by reversing the polarity on the posts.

And, yes, obviously I am not that smart when it comes to electrical things.

someone please help and let me know what i can do.

thanks, Eric

Share this post


Link to post
Share on other sites

did you charge the battery with the cables hooked up backwards??

use a test light and see where the voltage stops does it stop at the switch or the starter??

Jesse

Share this post


Link to post
Share on other sites

Jesse,

I gave you some help in the snowmobile forum. Check that out!

Share this post


Link to post
Share on other sites

that was iron ranger but non the less he should be able to find his problem and get it fixed

Jesse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0