Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
senco 1

Evenrude E-Tec

7 posts in this topic

I have a 2007 E-Tec that the tilt and trim will not hold the motor trimmed up when hitting bigger waves. Has anyone had this problem? I have had the manual release valve and the whole pump unit replaced.

Share this post


Link to post
Share on other sites

You say the whole unit has been replaced? Theres nothing else then. Is it still under waranty? take it to a dealer and have it checked again. Welcome to FM

Share this post


Link to post
Share on other sites

You might have some sort of circuit problem. Maybe when your bashing waves it causes the pump to engage somehow and you can't hear it? Just a guess. Good luck!

Share this post


Link to post
Share on other sites

I have a 2007 E-Tec that the tilt and trim will not hold the motor trimmed up when hitting bigger waves. Has anyone had this problem? I have had the manual release valve and the whole pump unit replaced.

When you say "Pump Unit" do you mean the electric pump, or the entire trim and tilt assembly?

marine_man

Share this post


Link to post
Share on other sites

I think I know what the problem is! The cable for the bow mounted trolling motor looks like it is hitting the trim switch. I will have to hit the water and check it out.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0