Guests - If You want access to member only forums on HSO. You will gain access only when you Sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
big catch

1980 25 hp johnson

5 posts in this topic

the boat runs good then it runs bad sometimes for 5 minutes sometimes the entire day. It always runs it just doesnt run as good as it should at all times. Ive had it to the shop twice and he tells me theres nothing else he can do. The compresions and everything else check out. Any ideas on what my problem could be. Tomorrow I'm trying a new gas tank.

Share this post


Link to post
Share on other sites

Does iut only do it when the engine is hot/warm? If so, I would put a new impellor in as it could be overheating. Same thing happened to my 96 25hp.

This winter I also have to clean the carbs. If that was not done yet, that would be my second thing to check. Good luck.

Share this post


Link to post
Share on other sites

Try replacing the o-rings in both connectors on your fuel line. If they get worn the engine will suck in air and you will get the symptom you describe. If it works its a very cheap fix.

Share this post


Link to post
Share on other sites

Welcome to Fishing Minnesota!

Can you provide a little more info about what your motor is doing when it runs bad? Is it only at when you're running at a higher engine speed, only at idle, at both?

marine_man

Share this post


Link to post
Share on other sites

I agree with the impeller, happened to my dad's 91 40 hp suzuki. Would run great, then start acting up randomly. The shop missed it the first time.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0