Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
superbee

Engine smells hot

11 posts in this topic

I just had the top end redone on my atv. It smells hot, do you think it would just be some of the oil and sealants burning off the engine or is something wrong. It seems ok and runs good, just smells real hot.

Share this post


Link to post
Share on other sites

It sould just be the oil and stuff burning off... nothing to worry about. Try using a heat gun to check just in case.

Share this post


Link to post
Share on other sites

I wouldn't worry about it at first. When my Kawi 750 was new it had that smell also till it burned off. I would just follow any instructions that the rebuilder recommended (run slow, change oil, etc..)

Share this post


Link to post
Share on other sites

I never thought of trying a heat gun, that's not a bad idea. I don't think it is anything to worry about, but wondered if anyone else ever noticed it or thought the same.

Share this post


Link to post
Share on other sites

i wouldnt worry about it. same thing happened to my friends polaris

Share this post


Link to post
Share on other sites

I 've been using a fair bit lately and working pretty hard, the hot smell has started to subside now. I think everything is good now.

Share this post


Link to post
Share on other sites

Are you working hard, getting all your bear out?

Share this post


Link to post
Share on other sites

Just the bait so far, the bears will be shortly.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0