Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
gofishingtom

shouldnt have done it!!!version 1.6 anybody have it

13 posts in this topic

Does anybody have the version 1.6 laying around on a chip?? had that on my LCX-27c and had no problems..but after talking to a bunch of people and scheels was convinced i had to update and did..but now the last time out when i go 30-35 mph i loose bottom..never had that problem with the version 1.6..unless im missing something ..but i'm pretty savy with graphs and have tried all adjustments..just hoping to go back to what i had on unit..so if anybody has it on a chip email me at gofishingtom@clearwire.net and i could give you my address and pay you for shipping and when done send it back to you..

thanks in advance

Share this post


Link to post
Share on other sites

Bad move for sure.

Calling Lowrance and waiting on hold for a long time is another option if you can't find the software from someone.

You won't have to ship the software it can be E-mailed to you.

Good Luck!

If it aint broke dont try and fix when it comes to Lowrance software upgrades!

Share this post


Link to post
Share on other sites

pier,

problem is i'm not sure i can load it on chip..i'm running vista and says nothing on websight about vista and tried to download other stuff and couldnt get it to work..

Share this post


Link to post
Share on other sites

I have done every update when they've come out and haven't had any problems or complaints with them ...... don't have the LCX 27 though so maybe that one's different ...... but I've liked the added networking features and haven't had a problem with losing depth readings like some people have reported.

Share this post


Link to post
Share on other sites

perch... i didnt hae any problems with mine until i got talked into upgrading to the 2.3 version its fine when i start out but once up on plan it loses bottom never did that before i could go 45-55 in my lund and never once lost bottom..now i do

Share this post


Link to post
Share on other sites

You don't here alot of problems with any of the new Humminbirds. I wonder if Lowrance isn't doing so good since Navaco baught them out. CS is tuff when on hold for so long. The guys you talk to at that store can get you the reps cell number. I know you will get a call then.

Share this post


Link to post
Share on other sites

Bad move for sure.

....

If it aint broke dont try and fix when it comes to Lowrance software upgrades!

Generally good advice for any firmware/software update, regardless of make/model, unless there is a known issue and your unit exhibits the problem.

Share this post


Link to post
Share on other sites

Nice call PB!

Just throwing it out there, but was there an upgrade inbetween the one you did and the original and you just jumped to the newest?

I know it might be remote, but some times you have to install in order.

Share this post


Link to post
Share on other sites

just got home buddy had to go to son's hockey game got home and no download from lowrance in email...maybe he will send it tommorrow..but i think im going to call again tommorrow..

Share this post


Link to post
Share on other sites

I thought I had the version you were looking for, but it is for the lcx-25c, sorry. I have updated to the very newest versions for my 112c and my 25c and have had no problems.

Sorry.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0