Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
redtrucks

Pontiac 3.1 EGR valve

3 posts in this topic

Put new head and intake gaskets in my daughters Grand Prix this spring and after I did that the service engine light comes on everytime she drives it but it seems like it only comes on when she applies the brakes. I'm assuming that she applies the brakes hard because I cannot get the light to come on when I drive it. The computer says that the service engine light is coming on from the EGR valve. I checked the wire connectors and they seem fine and I also took the valve apart and cleaned it. Still receiving the same code. Any thoughts of what might be the problem?

1994 Grand Prix 3.1

Share this post


Link to post
Share on other sites

Whats the code?

My guess is that it comes on when she hits the brakes because the computer is not seeing the correct "closed" signal from the EGR valve. The EGR should be closed when the vehicle decelerates or is idling. If it was stuck open you would likely notice the engine running rough and a really hard brake pedal.

Share this post


Link to post
Share on other sites

I don't remember the code number but it said "EGR performance". The car runs fine.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0