Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
fishlikemike

Clearwater Pro

6 posts in this topic

I just got a clearwater pro off HSOList power works great but can't register the bottom manual says bad transducer but it brand new in the box any suggestion other transducers that will work to try it out please help

Share this post


Link to post
Share on other sites

which transducer do you have? There is two different ones the self leveling and one that had a leveling bubble on it. They had problems with the first self leveling transducers the cold water did something to the cermics. Another thing run the gain about 3/4 of the way up.

Share this post


Link to post
Share on other sites

I have the one with the bubble in it, it also came with a leveling stick but I can't figure out how to mount the transducer to it.

Share this post


Link to post
Share on other sites

If it's like my old Classic the instructions said to use plastic tape. Seems to work OK.

Share this post


Link to post
Share on other sites

I use electrical tape and go right up the stick attaching the cord. I then use plastic clamps to attach it to my box over the hole. Works well. You only need the transducer just in the water. It does not need to be down in the hole. You will lose fewer fish if it is not deep.

Share this post


Link to post
Share on other sites

Thanks for the help guys used the electrical tape and took it to Mille Lacs this weekend worked almost as good as my Buddys vex but he invested 400$ and I got a whole 80$ with battery and charger all brand new.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0