Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
ethan77

motor porblem

5 posts in this topic

I have a 93 Evinrude motor that is a 70 horse.. what it is doing is stalling out.. I can trim the motor all the way up untill the prop is just below the water line and give it all the gas I want... but once I trim it down into the water to start going it stalls out on me.. doesn't do it all the time but when it does it puts a damper on my fishing.. any ideas? can anyone maybe fix that for me if you know what is wrong with it?

Share this post


Link to post
Share on other sites

Have you tried a new fuel filter?? Might not be the problem, but it sounds like something that could be affected by the level of the motor.

Share this post


Link to post
Share on other sites

Could the fuel line be pinched as you adjust the trim???

Share this post


Link to post
Share on other sites

When mine did something very similar to that I had to get the carbs rebuilt. Check and see if gas is running out the front of the motor when you trim it down. Hope you find out what it is!

Share this post


Link to post
Share on other sites

When the motor is trimmed up it changes the fuel level in the carbs bowls.
Inspect the fuel lines, bulb and connections. Replace the filter and see if it runs better. Next thing to do is check the fuel pump and clean the carbs.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0