Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
luckystiff

Lowrance 350A problem

6 posts in this topic

My Lowrance kept shorting out this weekend every time my aerator kicked on. It worked fine when the big motor ran, but acted up when I was drifting or running the trolling motor. The 350A is hooked up to the starting motor battery.
I hooked my dad's 350A up to see if it was in the unit, but it did the same thing. Is this a wiring, fuse or battery problem?
It also wiped out 102 GPS coordinates, is there anyway to restore these?
A frustated fisherman.....
Any help will be appreciated.

Share this post


Link to post
Share on other sites

The GPS spots are gone. Were you using a marine band radio? Is your starting battery a dual purpose or a crank battery? Its best to wire the unit to its own battery if possible.

------------------
Mille Lacs Guide Service
651-271-5459
www.millelacsguideservice.com

[This message has been edited by Derek Johnston (edited 05-27-2003).]

Share this post


Link to post
Share on other sites

Derek,
Thanks for the reply. The GPS spots were completely wiped off somehow. Everytime I shutdown the big motor, the depthfinder would remain on until the aerator would kick on. Then it would start flashing and beeping until I'd shut the aerator off. I do have a marine band radio, but didn't have it on all weekend. I'm not sure what kind of battery I have, but I know that my bilge, aerators, (front & back), and running lights are all running off of the back starting battery. 1999 Lund 1800 SE
Does this help?

Share this post


Link to post
Share on other sites

Has anyone else ever experienced losing all of your GPS coordinates on a 350A. Is there any way to restore these?
What kind of battery should I buy to run my 350A on alone?
Thanks!

Share this post


Link to post
Share on other sites

lucky, that's sucks about your coord's. You don't need a different battery for your electronics if everything's hooked up right.

Share this post


Link to post
Share on other sites

If its not a battery problem, do you suppose it could be a problem with the pins connecting the GPS? I'm still confused as to why this is happening. Anyone know if Lowrance can help or am I wasting a phone call?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0