Guests - If You want access to member only forums on HSO. You will gain access only when you Sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

  • Announcements

    • Rick

      Members Only Fluid Forum View   08/08/2017

      Fluid forum view allows members only to get right to the meat of this community; the topics. You can toggle between your preferred forum view just below to the left on the main forum entrance. You will see three icons. Try them out and see what you prefer.   Fluid view allows you, if you are a signed up member, to see the newest topic posts in either all forums (select none or all) or in just your favorite forums (select the ones you want to see when you come to Fishing Minnesota). It keeps and in real time with respect to Topic posts and lets YOU SELECT YOUR FAVORITE FORUMS. It can make things fun and easy. This is especially true for less experienced visitors raised on social media. If you, as a members want more specific topics, you can even select a single forum to view. Let us take a look at fluid view in action. We will then break it down and explain how it works in more detail.   The video shows the topic list and the forum filter box. As you can see, it is easy to change the topic list by changing the selected forums. This view replaces the traditional list of categories and forums.   Of course, members only can change the view to better suit your way of browsing.   You will notice a “grid” option. We have moved the grid forum theme setting into the main forum settings. This makes it an option for members only to choose. This screenshot also shows the removal of the forum breadcrumb in fluid view mode. Fluid view remembers your last forum selection so you don’t lose your place when you go back to the listing. The benefit of this feature is easy to see. It removes a potential barrier of entry for members only. It puts the spotlight on topics themselves, and not the hierarchical forum structure. You as a member will enjoy viewing many forums at once and switching between them without leaving the page. We hope that fluid view, the new functionality is an asset that you enjoy .

Recommended Posts

9 minutes ago, smurfy said:

Him and a whole lot of others. I got thick skin so don't take to much here real serious.

We wanted our freedom to post so we went to where it was accepted.  

Basically there are different ways to cook a "roast".   It can be cooked at various temperatures in an oven, a smoker, or a sous vide, or it can be braised in a crock pot or a dutch oven.    If the cut has a lot of collagen and is therefore tough it is tricky to cook it so it stays pink yet will be tender.    

Braising  or 'pot roasting" will make it tender but it will be cooked well done.   It is quite a different thing than "roast beef", although I like it a lot.

Share this post


Link to post
Share on other sites

Ya, this sure went south from a lot of those who always quacked about threads going south. Follow that analogy.

Gotta disagree with ya on the braising bit though, Del. It won't always be "well done" by the time it's tender. I atill like to follow the pork rule of "low and slow" for most meats.  But, a roast is always good unless ya totally fudge it up. Now ya got me wanting to make one...think I'll go dig around in the freezer, know I've got one buried in there somewhere, just waiting to be melded with aromatics and tasty sauces...:P 

"Beef, it's what's for dinner!"

Share this post


Link to post
Share on other sites
5 minutes ago, bobberineyes said:

Well said del. Well mike since your roast thread got cut up so did the roast. Waiting for the coals but here is the bacon wrapped beauty's waiting for the cast iron..

 

20171119_171311_resized.jpg

Awe GAWD, your ruining it with the bacon!!:P:grin:

Share this post


Link to post
Share on other sites
18 minutes ago, bobberineyes said:

Well said del. Well mike since your roast thread got cut up so did the roast. Waiting for the coals but here is the bacon wrapped beauty's waiting for the cast iron..

 

20171119_171311_resized.jpg

 

 

Cripe-o-rama!  Now THERE's some real beef cookery!!!  And just ignore dat  babbling little smurf, boober! :D

Share this post


Link to post
Share on other sites

By the way, if anybody has an open mind and wants to try sous vide, Amazon has a great price on the Anova device as "deal of day" today.    yeah yeah, Reb.  

Edited by delcecchi

Share this post


Link to post
Share on other sites
On 11/16/2017 at 11:02 AM, Mike89 said:

Hey all, I need a good recipe a good moist beef roast, I use chuck, bottom round and other cuts so a good all around recipe would be great!!! 

 

thanks....

CRIPES MIKE..................look at the bafoonery ya started!!!!!!!!!!!

Share this post


Link to post
Share on other sites
1 hour ago, smurfy said:

CRIPES MIKE..................look at the bafoonery ya started!!!!!!!!!!!

yup I guess I did and nobody wants to spell RH's name right I see......:lol:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




  • Posts

    • We the People 1911   I am thinking this will be my next gun.
    • I have a question for all of you AV wizards out there. In my house I have 4 or 5  flat screen TV's connected directly to Mediacon cable. No cable box. The only problem to this is my channels are digital channels so Fox 9 is actually on 9.9 and ESPN is on 66.5, etc.  I just recently acquired an older flat screen tv for my garage from a friend who didn't want it anymore. It is about 10 years old.  When I hook it up to cable and try to run the auto programming feature it doesn't find anything.  Could that TV just be too old to do what I am asking? I can get a cable box from Mediacom but I'm trying to avoid that. Any ideas?
    • I understand that the block heater doesn't warm the truck. It does warm the block which in turn heats the antifreeze which circulates through the heater core. The quicker the antifreeze heats up, the quicker the heater in the cab is blowing warm air. I am simply trying to cut down on idling time in the driveway. During the week the only time it's driven is quick trips when the wife is not home. Her vehicle is what's driven most of the time.  My my main concern was leaving the pickup plugged in all the time and causing some other sort of issues with the engine. 
    • How hard has he been running this 400 HP rig? Might be as simple as a plug wire or might require a compression test. 
    • Get the choke adjusted that should take care of the cold start issue. A weak fuel pump usually starts to show up at high RPMs.   If left to idle the fuel pump fills the carb bowl, as you accelerate the weak pump can't keep up and the engine bogs and bucks.  A bad fuel filter will do the same thing and is often overlooked. You probably have 2 filters,  one on the gas line and one inside the inlet of the carb.  Replace them, don't clean them.   A  fuel pump pressure test would be the next thing to do.   If your getting the bog throughout the power band then I'd suspect something electrical but it could show up just at higher RPMs or load as well.  Condition of plug wires, dist cap, rotor, pickup coil, and vacuum advance.  1st check all the vacuum lines for cracks and loose connections.  Something that old is bound to have bad lines.  While your at it clean the PCV vavle.  Google HEI distributor to test the pickup coil and ohm values.   Check the linkage to vacuum advance.  You can do a visual on the cap and rotor but its hard to find a hairline crack.   Keep us updated.  
    • I was seeing the same things on the lakes in Roseville/Shoreview. I assumed that with the cold temps over night the ice was growing and expanding causing a few of those cracks to show up.  Maybe some of the light snow helped push the ice down enough to let a little water seep through.
    • Tried wiring the choke open at operating temp and took for a drive. Still misses at appx 45 mph. Always seem to miss about 90% of the time at that speed although sometimes at around 30mph. Next question,,, fuel pump maybe or possibly the EGR VALVE. Dont have a way to test the fuel pump but thinking with the way its hard to start I was thinking possibly low fuel pressure. 
    • Bald Eagle skimmed over on Saturday.  Today after the relatively light snow there are many areas where the cracks look like water came up through and discolored the ice.  At least that what I think happened. Since there was only an inch or so of snow I am surprised that it pushed the ice down and let water come up.  Anyone else have an explanation?
    • I am assuming it was either an Ion, SM Lithium, or drill setup... If it is, no need for a slush copter. I put my slush bucket over the hole... drill... then reverse. In 12" of ice I can do 6 holes with one dump of the bucket. Every 6" beyond that takes another dumping of the bucket.
    • I have the parts on order to get the unit set up for the ice.  I ended up buying a marcum lithium shuttle for my LX7 and then plan to mount the Helix on the shuttle that came with my LX7.  I am hoping to find walk-able ice in my area this weekend and hopefully the parts show up before then so i can give it a go.  I have the pre-chirp model of the helix so with a little luck i can get them to cooperate.
  • Our Sponsors