Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
clam up

LazerMag Ultra problem or maybe not??

5 posts in this topic

Got a brand new Lazer w/2 hp tecumseh power. When drilling, I seem to be experiencing some excessive clutch slipping. After this occurs, I can smell the results. I'm somewhat of a motorhead so I can tell good smells from bad ones and this is not great. It smells like a burning fan belt in a car. Just curious as to if I should be worried or if I should just ease up on her a little. I don't apply any pressure to it as it's weight carries it down plenty fast. Anyone else experienced this? I sure would appreciate any help.

Share this post


Link to post
Share on other sites

I would give Strikemaster a call. We had gearbox problems where the gears were binding and you had to have it almost wide open for the blade to start turning. Well in the end SM ended up replacing it with a new power head. The people at SM are good people to deal with. Good luck!

----------

Fishn'Lady

Share this post


Link to post
Share on other sites

As Fish'n Lady said, get ahold of Strikemaster and they will take care of you. I have a Lazer Mag Ultra and I'm very pleased with mine.

Share this post


Link to post
Share on other sites

Get a jiffy. Just kidding to each his own. Call them they do a good job. I just had a polar vision that was 3 years old that was giving me problems they just sent me a new one.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0