Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
herm0026

Lowrance HDS 5 ?s

3 posts in this topic

Just purchased a new boat with a lowrance hds 5 on it... Does not seem to have a clear view of the bottom, seems to have alot of feedback between the transducer and the bottom. Also had problems with the gps not working correctly. took it in to the dealer today.. seemed to work fine there! then when i got out on the lake it was back to messing up.

also when i put my lake master chip in at Cabelas the incite mapping would work with the chip for a more detailed map, mine does not do that....

Share this post


Link to post
Share on other sites

Sounds like you might have electrical interference or you're running another sonar at the same time on your boat? Did you test your HDS at the dealer while running the motors and other electronics? That probably be your best next step in figuring out the problem with your graph.

Not sure about the GPS, what are the symptoms?? I'm pretty sure that Insight lakemaps and Lakemaster chips don't interact, might be mistaken. I've only run Navionics in my HDS so far.

Share this post


Link to post
Share on other sites

You should read Perchjerker's post regarding a similar question HERE!

Having your software up to date and the correct transducer selected are good checks. You'd think the dealer would have checked that, but who knows.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0