Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
Scupper

Another one for the experts...

3 posts in this topic

2000 GMC Yukon XL, 170,000 5.3

Late yesterday while sitting at a traffic light I pushed on the air conditioning button. A few seconds passed and the engine stalled. I restarted and feathered up the foot feed only to have the engine stall again. I turned off the air conditioner and restarted and the engine. It ran fine.

Once at home I couldn't resist again turning on the AC. Same thing, engine stall except this time I heard some groaning before the stall out and noticed an hot electrical smell or some type of belt burning smell.

I'm 2 days out from dropping it off at the shop and thought I would run it by the experts on here as the answers are I have received in the past were spot on. wink

Thanks.

Share this post


Link to post
Share on other sites

Sounds like the A/C Compressor is locking up!

Share this post


Link to post
Share on other sites

Agree, you should be fine if you leave the a/c off. New compressor time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0