Guests - If You want access to member only forums on HSO. You will gain access only when you Sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

  • RECEIVE THE GIFTS MEMBERS SHARE WITH YOU HERE...THEN...CREATE SOMETHING TO ENCHANT OTHERS THAT YOU WANT TO SHARE

    You know what we all love...

    When you enchant people, you fill them with delight and yourself in return. Have Fun!!!

Sign in to follow this  
CraigM

? for outboard guru's

Recommended Posts

I have an Evinrude 175 Intruder and have a question. There is a fitting on the front of the motor just above the cavitation plate. On other motors I have seen a hose running from the fitting up into the housing somewhere. Mine is missing this hose. Where does it go and what does it do? Is there any harm in running without it? Thanks

Share this post


Link to post
Share on other sites

I hadn't even thought of that. Makes sense, the speedo is running off a transom mounted pick up so I guess I don't need to hook that one up. Thanks.

Share this post


Link to post
Share on other sites

I have the 150 Intruder. I have a fitting with no tube on it also. I love mine, it is a hard running beast. I hope you like yours too.

Share this post


Link to post
Share on other sites

That is the case... it's the speedo tube pickup.. if it's not connected and your speedometer works there's no problem with it the way it is.

marine_man

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this