Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
vikingmeatwad

Stereo not powering up

6 posts in this topic

Bought a boat and I want to fix the stereo but I'm stuck.

Fuse is good but no power going to the stereo when I check the power wires.

Tried every switch in the boat and I am having a hard time tracing the wires as it is a glass boat (Stratos 386xf)

Let me know if any ideas. Thanks!

Share this post


Link to post
Share on other sites

Could there be multiple fuses? Check for an inline fuse, fuse block, fuse at the back of the stereo, etc.

Share this post


Link to post
Share on other sites

I only found the inline fuse past the wiring adapter. I checked for power at the adapter and found nothing.

Share this post


Link to post
Share on other sites

Does your boat have a fuse block? I assume it does. There should be a fuse for the stereo in there. If not, there should be an inline fuse at the battery for the stereo.

Share this post


Link to post
Share on other sites

try hooking the radio direct to the battery see if it works

Share this post


Link to post
Share on other sites

Thanks to all for the input, I will check the inline fuse again and try to chase the wires to see where it leads.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0