Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
concreteman

Trim/tilt question i need of desperate help anyone?

5 posts in this topic

Fella's I'm in need of anyone kind of answer, clue, guess whatever. I have a 99 evinrude ficht 175 and my trim stop working. I checked the trim motor and that works, went through the relays those were good. Went the through the switches checked the 3 of those and getting 12 volts going both directions up and down but as soon as i hook the trim motor up i get nothing. To me its seems like im not getting a ground now i cant find a ground wire that is bad, burn socrched anything. Anyone have any ideas it would be much appreciated

Share this post


Link to post
Share on other sites

Does it work at all? - My 175 Johnson trim/tilt went out last fall and I did the same things. I finally brought it to a dealer and they found the problem in the shift panel wiring on the start key switch.

Share this post


Link to post
Share on other sites

my trim went out too, I found that it was just in need of a flush and new fluid at 170 bucks which was good, take it in.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0