Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
mww24

need humminbird help

2 posts in this topic

i have a brand new humminbird 727. From the day i got it the depth reads 3.5 feet. it doesnt matter how shallow or how deep i am or how fast or slow i'm moving. When i turn it on with the transducer out of the water i hear it clicking like its working, but no matter what settings i try or no matter how many times i reset it it does not work. any ideas. thanks.

Share this post


Link to post
Share on other sites

When you boot it up, go into the test mode and check for connectivity between the unit and the transducer to begin with. If it shows it reading as connected, then I would probably call Humminbird service and ask them. Its rare, but possible it will need to be sent back.

Google up "Unofficial Humminbird Forum" and post a message and Greg Walters from Humminbird will typically answer within half an hour. not all the time, but for the most part, he is there in a very short time.

Cant post a link here without getting my hand slapped, so youll have to google it yourself.

R

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0