Guests - If You want access to member only forums on HSO. You will gain access only when you Sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
fishhuntwork

Lowrance 520c Problems

16 posts in this topic

I've had my Lowrance 520c for 2 years, this is my second year using it. This year I've had more problems with it losing depth, or saying I'm in 1.7 ft of water. It seems to come back when you start to increase speed but then it loses the depth again. I've tried the new beta update with no luck. Any ideas of what it could be or what should be tried next.

Share this post


Link to post
Share on other sites

Not too sure. If you want you can use my boat to test it out on. Let me know today or tomorrow.

Share this post


Link to post
Share on other sites

I've had my Lowrance 520c for 2 years, this is my second year using it. This year I've had more problems with it losing depth, or saying I'm in 1.7 ft of water. It seems to come back when you start to increase speed but then it loses the depth again. I've tried the new beta update with no luck. Any ideas of what it could be or what should be tried next.

I'm having the exact same problem. I've tried everything - I thought it might be a dirty transducer but it still does it. I guess it is time for a trip to Fish Electronics.

Share this post


Link to post
Share on other sites

I thought it maybe a transducer problem too, but I really don't want to have to good transducers or be without a locator this summer. I guess I'll call lowrance and see what they say.

Share this post


Link to post
Share on other sites

i have that same problem but on bow only and its wired

to a unverisal transducer in the trolling motor and some one told me thats maybe whats going on

the one on the dash works fine

Share this post


Link to post
Share on other sites

I think there was a post on this same locator having the same problem about a month back? I think must were taking it in to get looked at? frown

Share this post


Link to post
Share on other sites

Mine is on the dash and it reads the 1.6 or 8.8ft. Its the unit.

Many people are having issues with these units. I tried to call Lowrance for 2 days but could not get through. I also e-mailed them 4 days ago with no response.

With the issues I had with the H20 power cord and now this with no CS, this will be my last unit from Lowrance.

Share this post


Link to post
Share on other sites

I got through to lowrance today after being on hold for 40 mins, they said to try a diffirent transducer first and if that doesn't help send it in. So now I have to move my 520c to the bow and my 135 to the console.

Share this post


Link to post
Share on other sites

Unfortunatley I have the same problem w/ lms332c(reads 1.8 feet), so I called lowrance and was told to try my unit on a buddy's boat so I did and it worked perfectly even at high speeds. AAARRGGH, I'm thinkin the problem is on my end. I moved my transducer cables away from my motor cables and it helped but it still flips out occasionally. I guess the next step is to move the transducer until I get it dialed in. Very frustrating to say the least so i bought a high speed transducer for my FL20 and have been using that as a backup until I squash the bugs in my lowrance. If this doesn't fix it I'll prolly be lookin at a bird.

Share this post


Link to post
Share on other sites

I've got the same unit and the same problem!

Share this post


Link to post
Share on other sites

I have the same unit with the same problem too. I am going to upgrade it from version 1.4.0 to 2.4.0 and if that dosent work I will try the beta version 2.4.2. I am really unimpressed with this $500.00 peice of junk. I thought spending the money on a so called good one would eliminate all the problems. Guess not.

Share this post


Link to post
Share on other sites

Same problem with mine. Called Lowrance,8:30a.m. waited 45 minutes to talk to someone. (Love that customer service) Guy was friendly, but basically told me nothing I haven't read here. Bought a new ducer today, but I'm going to try the soft reset first. By the way what's the difference between soft and hard reset?

Share this post


Link to post
Share on other sites

Soft Reset means you will not loose data.

Hard Reset means you will loose saved data, data once saved by the after factory user, such as saved waypoints and trails will be lost. So be sure to save Waypoits, Trails, and Routs to a blank SD Card before doing a Hard Reset to be reinstalled again latter on.

Share this post


Link to post
Share on other sites

Have the same unit and same problems but if I drive slow it don't do it so much. But I was on mille Lacs yesterday some good waves and driving faster then usual and the grafph didn't loss bottom once ,what gives?

Share this post


Link to post
Share on other sites

Today I used my 332 that suffers from the same problem(1.7') on a different boat w/ my buddy's suction cup transducer and worked great all day. I think the problem is w/ the transducer itself or it's mounting position.I'll be moving/replacing mine asap to verify this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0



  • Posts

    • Hey @rl_sd who had the meat on sale? Looks great btw
    • chicks maybe exploring what the beak is for
    •   You can also be a little creative with the leftover meat.  For example: The wife and I will whip up a spanish rice mixed in with the pork and make Enchiladas or heat the pork on the stove top, mix in some BBQ sauce and make quesadillas (the grandkids love them).   There's more to pulled pork than sandwiches.  
    • that is great!!!!   good for you guys!!!!
    • Your right rs_ld,  a full smoker is the way to go, leftovers can always be frozen and re heated..good eats.
    • 195 degrees on these butts. Like they say, if you are going to spend 9 hrs smoking 5# of meat, you just as well spend the same amount of time smoking 45#. The local grocery had these on sale so had a few friends take the offer to throw a roast on for them. Took two off early for slicing  Pulling the rest cost them each a beer though!
    • Very good stuff, kinda tasted like ribs with this recipe,  I'll keep at it til I find the right one!! Good luck moon lake!!
    • It will be interesting to see how the Warriors react in free agency.  Will they be able to keep the team together?  It seems like all these guys value winning above a paycheck so they might be willing to sign deals that will still allow the team flexibility to keep good role players around them.    
    • That's too bad.  The fish were ON FIRE up there.  I went out with my dad and uncle with our tiller walleye boat, and hardly a clue what we were doing, and we crushed them!  Ended up with 118 pounds of packaged salmon fillets.  I think I can honestly say it was the most fun fishing trip I've had in my life.  Here's my biggest of the trip, 25 pounds.    
    •   It's amazing to see a thoroughly talented team like Cleveland just get dissected like a back alley pick up team. I agree--GS will be THE team to beat for several more years if they keep their nucleus. I think we can make them sweat a little bit now, though, so that's pretty exciting for a change! 
  • Our Sponsors