Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
straydog

Goofy fuel guage in Buick Lasabre

4 posts in this topic

We have an '02 lesabre some times the fuel gage works some times it doesnt. Seems like when it is over half a tank it works fine but when it goes below half it some times reads full, some times reads emty and some times reads right. Any one have any experiance with this?

Share this post


Link to post
Share on other sites

Ford has a problem similar to this in some models. They claim it's from a higher concentration of sulfur in certain brands of gas that builds up on the fuel sender and gives a false reading. Of course I thought it was all [PoorWordUsage] but I did try the recommended Techron brand injector cleaner and the problem went away. This has happened 3 times so far and the injector cleaner has worked each time.

Share this post


Link to post
Share on other sites

Its likely the sending unit in the tank. The good news is they get replaced when the fuel pump goes bad. The bad news is they are not cheap. A can of cleaner in the tank couldn't hurt.

Share this post


Link to post
Share on other sites

Thanks guys I will try a can of cleaner but I dont have alot of faith as it has been doing this for a few years now, I really appreciate the help I get on here, Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0