Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
gunmunky

91' Yamaha Starter Problems

5 posts in this topic

I have a 91' Yamaha Moto 4 350 and now when I try to start it I hear a fast clicking noise but the engine doesn't turn over. Do I need a new starter or is there maybe an easier fix? Where is a good place to get a starter if that's what I need? Thanks for any help!

Share this post


Link to post
Share on other sites

Sounds like a weak battery to me. Try to start it with a jump and see if the starter works.

Share this post


Link to post
Share on other sites

Anytime I've seen this on any of my machines it was either a bad battery or a loose battery connection.

Share this post


Link to post
Share on other sites

Good idea. I have a trickle charger hooked up right now but I will hook my regular charger up and see if that works. Thanks for the quick replies.

Share this post


Link to post
Share on other sites

Had the charger hooked up and tried it last night and it started!!! Thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0