Guests - If You want access to member only forums on HSO. You will gain access only when you sign-in or Sign-Up on HotSpotOutdoors.

It's easy - LOOK UPPER right menu.

Sign in to follow this  
Followers 0
NETim

lowrance 2.4.2 (beta) loaded on my 520C's

2 posts in this topic

I went ahead and loaded 2.4.2 on both of my 520C's this past weekend. Both seem to work fine although I really didn't test out the shallow water issues because we didn't fish any weeds.

One new option I noticed (going from 2.3.0) is this s/w allows the user to choose the type of transducer being used. Fortunately the xducer cable coming up from the "main" xducer in the rig is labeled so I was able to select it properly I believe.

However, I've got a MK Terrova up front with their built-in xducer. I just went ahead and picked "generic 200KHZ" for that unit. Forward 520 seemed happy and I got a nice clear display. Maybe I should've experimented but it looked good.

Anyone else with experience with the 2.4.2 s/w?

Share this post


Link to post
Share on other sites

I made the switch to 2.4.2 and it's helped me out. I am curious as to what will happen when the algae bloom starts up on a few of the lakes.

I did take the time to mess with the different transducers the other day and found that the genaric 200 kz was definately the best for my x27.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0